About MartNet MartNet Technical Support
Home Services Support Members Software Contact
Search Support
MartNet WebMail

MartNet WebAdmin

Dialup Access
  Numbers

Domain Name
  Management

MartNet News /
  Status Info

NOC / System Status


Support Topics:
 MartNet WebAdmin
 Dial-up
 Virtual Hosting
 Web Site Construction
 Unix / Linux
 E-Mail
 Internet Chat
 Game Server Services
 Misc. Stuff
 Policies / Legal





FAQ's:
 MartNet WebAdmin
 Dial-up
 Virtual Hosting
 E-Mail
 Game Server Services
 Misc. FAQ's

Links:
 Privacy and Security
 Dial-up
 Web Development
 E-Mail
 Unix / Linux
 Game Server Services
 Misc. Support Links




MartNet Policies
Billing Dept.

Check Domain
Availability:



Using Netscape
Using Netscape to FTP (copy) files

In addition to using Netscape to browse the World Wide Web, you can also use Netscape to transfer files between your computer and your account on one of MartNet's machines. The way that Netscape transfers files is by using File Transfer Protocol (FTP). FTP is a standard method for transferring files over the Internet.
If you use FTP to transfer files, you do not need to be concerned with encoding or decoding binary files. A binary file, such as a graphic, a compiled program, or a file created using a word processing or spreadsheet package, contains computer instructions. A word processing file, for example, contains instructions for margin settings, character formatting, and font size.

A text file (or ASCII file), on the other hand, contains only characters and does not contain computer instructions. Most word processing programs have a Save As feature with a text option that allows you to take out the formatting instructions and save the characters only.


Using FTP to access your account
To upload files from or download files to your Linux account using FTP:

  1. Start Netscape.
  2. In the browser window, click on the Open button.
  3. Type ftp://userID@system-name. For example, if you have an account on martnet and your userID is jdoe, you would type ftp://jdoe@martnet. Then click on Open.
  4. When prompted, type the password for your account and click on OK.
  5. A listing of the files and subdirectories in your home directory will appear. Files are shown as documents with the top right corner folded. Subdirectories are listed as file folders. To access a subdirectory, just click on the subdirectory name or folder icon.


Uploading a file
To upload a file from your PC or Mac to your Linux account:

  1. Access the directory where you want to store the file as described above in step 5.
  2. Select Upload File from the File menu.
  3. If you are using a PC, click on the Files of type box and select All Files.
  4. Select the folder or directory containing the file you want to upload. Then click on the filename and click on Open.
  5. Click on OK if notified that the file was uploaded successfully.


Downloading a file
To download a file from your Unix account to your PC or Mac:

  1. Access the directory where the file resides. Then, if you are using a PC, continue on to the next step. If you are using a Mac, go to step 6.
  2. Click on the file using the right mouse button. Then select the Save Link As option.
  3. Specify the folder where you want the file to be stored.
  4. A filename will appear in the File name box. You can either accept this filename or type a new one. If the file does not have an extension, Netscape may append an .html extension to the file name. Unless this is an HTML file, however, make sure to overwrite this extension with something else to prevent the file from being saved in HTML format.
  5. Make sure the file type is set to All Files (*.*). Then click on the Save button.
  6. If you are using a Mac, click on the file you want to download and drag it to either your desktop or to a folder. Then release the mouse button. A copy of the file will then be saved in the location you specified.

Binary files that you download, such as word processing or spreadsheet files, may appear as generic icons that are not associated with a particular program. The appearance of the icons depends on how the Netscape Helper Applications are set up. If you cannot open a file by double-clicking on the icon, start the appropriate program, such as Microsoft Word or Excel. Then select Open from the File menu. Make sure all files are displayed (not just those belonging to that program?s type), and select the file.


Note that, depending on your editor, text files that you download may appear with improper spacing. If this occurs, try viewing the files using Netscape by performing the following steps:

  1. Select Open File from the File menu.
  2. If you are using a PC, select All Files (*.*) in the Files of type box.
  3. Select the file and click on Open.

As an alternative to downloading a text file, you can click on the filename in the FTP window to display its contents. Then highlight the text, copy it by selecting Copy from the Edit menu, and paste it into a word processor or other program on your PC or Mac by selecting Paste from the Edit menu.



This Web Site is proudly built upon an Open Source foundation:
Assembled with PHP Powered by Debian Linux Fueled by MySQL
Served by Apache

Home | Services | Support | Members | Software | Contact

MartNet - PO Box 42472 Philadelphia, PA 19101
Copyright 1996 - 2015 MartNet Communications LLC. All Rights Reserved.